Salesforce Outbound Email Deliverability Issue

Incident Report for Orion Advisor Technology, LLC

Resolved

This incident has been resolved.
Posted Sep 04, 2026 - 14:01 CDT

Monitoring

We are aware of an issue affecting outbound email delivery from Salesforce. While Salesforce is generating and sending emails successfully, a third-party email provider is currently rate-limiting email delivery, which may result in delayed or undelivered messages for some recipients.
 
Orion is actively monitoring the situation while Salesforce works with the third-party provider to restore normal email delivery. We will provide additional updates as more information becomes available. We apologize for the inconvenience and appreciate your patience.
Posted Sep 04, 2026 - 07:44 CDT