Client Portal Portfolio Values

Incident Report for Orion Advisor Technology, LLC

Resolved

This incident has been resolved.
Posted May 04, 2026 - 14:11 CDT

Investigating

We are addressing an issue where portfolio values in the Client Portal may appear inconsistent across views due to a recent update.
Thank you for your patience as we work toward a resolution.
Posted May 04, 2026 - 11:34 CDT
This incident affected: Platforms (Client Portal).