Important Update: Review Needed for Dynamic Model Allocations
Incident Report for Orion Advisor Technology, LLC
Resolved
The Dynamic Models issue has been resolved. Impacted portfolios are on a "Needs Analytics" status and can be run by clients as needed. We apologize for the inconvenience.
Posted May 01, 2024 - 10:53 CDT
Investigating
We have identified an issue with target allocations in Dynamic Models where target percentages may appear inaccurate. This issue is currently affecting only firms using dynamic models. We are actively working on a solution. In the meantime, we encourage clients to carefully review their rebalances before executing trades.
Posted May 01, 2024 - 09:53 CDT
This incident affected: Platforms (Eclipse).