Inbound Email Delivery to Orion

Incident Report for Orion Advisor Technology, LLC

Resolved

The issue impacting email delivery to Orion email addresses has been resolved. Service have been restored, and validation confirms normal email processing has resumed.

Senders who received an undeliverable notification during this timeframe may need to resend their message.

Thank you for your patience.
Posted Aug 14, 2026 - 11:56 CDT

Monitoring

Our teams have identified the source of the email delivery issue as a third-party email routing provider and implemented a mitigation to reduce the impact. We are now seeing successful email delivery from external senders and continue to monitor recovery.

Some emails sent during the impact window may still be delayed as email systems process queued messages. Clients who received an undeliverable or bounce-back notification should resend those emails, as they are not expected to be automatically delivered.

We will continue to monitor the issue and provide additional updates as we validate full service restoration.

We apologize for any inconvenience and appreciate your patience as we work to ensure email delivery has fully recovered.
Posted Aug 14, 2026 - 10:48 CDT

Investigating

We are currently investigating a third-party vendor email-delivery issue that may be preventing some emails sent to Orion email addresses from being received. Our teams are actively working to identify the cause and restore normal email delivery as quickly as possible.

Clients attempting to contact Orion who receive an undeliverable response may be impacted. We are continuing to investigate and will provide additional updates as more information becomes available.

If you need to contact Orion, please use Contact Us in Orion Connect or submit a case through the Orion Support App.

We apologize for any inconvenience and appreciate your patience while we work to resolve the issue.
Posted Aug 14, 2026 - 09:41 CDT
This incident affected: Orion Internal Systems (Orion Email).