FIX Connection – Update Delays Identified

Incident Report for Orion Advisor Technology, LLC

Resolved

This incident has been resolved.
Posted Jul 24, 2025 - 15:43 CDT

Investigating

We’ve identified an issue where some FIX connection messages are updating in the system, but some orders may not update within the system as quickly as they are filled.

Our team is assembled and actively monitoring the situation. Orders are being sent and received as expected, and normal trading processes can continue.

For the most accurate order status, please confirm directly with the custodian.
Posted Jul 24, 2025 - 15:17 CDT
This incident affected: Platforms (FIX Trading).