Eclipse Trading Platform Access Restored

Incident Report for Orion Advisor Technology, LLC

Resolved

The intermittent access issue affecting the Eclipse trading platform has been fully resolved. Users should now be able to log in and access all features without delays or disruptions. We appreciate your patience as our team worked to restore full functionality.
Posted Jun 26, 2025 - 14:10 CDT

Investigating

We have identified an intermittent access issue on the Eclipse trading platform, affecting user connectivity and performance. Users already logged in may experience delays or inability to launch applications and features. Our team is actively working to resolve this issue and will provide an update as soon as possible. We appreciate your patience and understanding.
Posted Jun 26, 2025 - 13:45 CDT
This incident affected: Platforms (Eclipse).