Orion Support System Delays

Incident Report for Orion Advisor Technology, LLC

Resolved

This incident has been resolved and Orion is working through delayed requests with priority.
Posted Jun 27, 2025 - 10:54 CDT

Update

We are continuing to investigate this issue.
Posted Jun 26, 2025 - 12:02 CDT

Update

We are continuing to investigate this issue.
Posted Jun 26, 2025 - 11:40 CDT

Investigating

We are currently experiencing delays in receiving email communications to Orion. For immediate support, please reach out to us at Orion Connect > Contact Us or submit a case via Orion Support.

The issue is only for email submissions, submission of cases through our site is operating as expected.
Posted Jun 26, 2025 - 11:38 CDT
This incident affected: Platforms (Orion Connect).