The intermittent access and performance issues affecting Orion Connect have been fully resolved. Clients should now be able to log in and use the platform without disruption.
We appreciate your patience and understanding while our team worked to restore full functionality. If you experience any continued issues, please contact our support team for assistance.
Posted Apr 14, 2026 - 12:17 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 14, 2026 - 11:45 CDT
Investigating
Orion Connect is experiencing intermittent issues, causing some clients to encounter slow performance or difficulty accessing their accounts. Our team is actively working to restore full connectivity as quickly as possible.
We apologize for the inconvenience and appreciate your patience as we work toward resolving the issue.
Posted Apr 14, 2026 - 11:32 CDT
This incident affected: Platforms (Orion Connect).