Performance Issues with Amazon Web Services (AWS

Incident Report for Orion Advisor Technology, LLC

Resolved

This incident has been resolved.
Posted May 13, 2026 - 12:51 CDT

Investigating

We are currently experiencing performance issues related to our third-party service provider, Amazon Web Services (AWS). System availability and performance is a top priority for both Orion and AWS, and AWS is aware of and actively working to resolve the issue.
We will keep you informed as updates become available.

Thank you for your understanding and patience during this time.
Posted May 08, 2026 - 11:02 CDT
This incident affected: Platforms (Orion Connect).